Mac OS X

  • CloudApp 3.5 Requires Mac OS X 10.9 or later Mac App Store
  • CloudApp 3.5 Standalone Requires Mac OS X 10.9 or later Download

Windows

  • CloudApp 3.5 Requires Windows 7 or later Download

Previous Versions

Running an older version of OS X or looking for a previous version of CloudApp? Download one of these releases. Please note these releases are no longer updated.

  • CloudApp 1.5.6 Unsupported Requires Mac OS X 10.6.6 or later Download
  • CloudApp 1.0.3 Unsupported Requires Mac OS X 10.5 or later Download
  • Courier Upload files to CloudApp (Requires Courier 1.0) Download